Thursday, August 26, 2021

TFMX!!

WHAT A CHALLENGE this is being! working, then not working, THEN when I got it working on the sidbox the audio was all garbage, then i got it working-ISH, it would play but the samples would play too fast making it sound like theyre ringing, but you could tell what it was playing.

Anyways, after not being able to fix it, im back to the drawing board, though my original sourcecide still works, i’ve not got it compatible with the sidbox yet.

I am still working on it, but I have alot of pressure to get this to work, becuse I want it working!!

So right now, back to the drawing board…

Friday, August 20, 2021

Sidbox 5 and the glitchy audio

After what seems like ours and believe me a few times I really wanted to just throw the damn project out the window… Glad I didn’t however.

Turns out it was my mixer! It came to light when I thought, about recording the glitchy sound so I could see what it was happening… Was strange as it when played back the glitch wasn’t there!?

I recorded a few more samples and the glitches where there, random and always sounding like scratching or pops… but when played back, the scratches were not there either!

I then thought just plug the to another audio mixer (much cheaper much older and thankfully still worked) it played lovely, no glitches or if there was I couldn’t hear them.

I plugged in the Neelix Adaptor to test a few games, Sanxion, Auf Monty, Tetris, and now Bionic Commando (as I write this hasnt finished loading yet)

They all worked!

I also found that the External Ram on the sidbox is not as secured as I thought it would be so it introduced some strange sounds, SO at the moment all the audio buffers are stored on the internal RAM (of which there isnt much left and I still have to write the OS)

(also Bionic Commando Loaded just fine too!!!)